Setup Rabbit MQ

Enable webserver
sudo rabbitmq-plugins enable rabbitmq_management

New user
rabbitmqctl add_user test test
rabbitmqctl set_user_tags test administrator
rabbitmqctl set_permissions -p / test “.*” “.*” “.*”

HP Bl460C G6 Centos7 RAID tool

Works on my HP G6 servers with this in lspci
0c:00.0 RAID bus controller: Hewlett-Packard Company Smart Array G6 controllers (rev 01)

wget http://mirror.nforce.com/pub/software/raidtools/hpacucli-tool/hpacucli-9.40-12.0.x86_64.rpm
yum install hpacucli-9.40-12.0.x86_64.rpm
hpacucli ctrl all show status

Will probably show as “Error: No controllers detected.
Run modprobe sg then re-run hpacucli ctrl all show status

With any luck you will see somehting like

 /usr/sbin/uname26 hpacucli ctrl all show status

Smart Array P410i in Slot 0 (Embedded)
   Controller Status: OK
   Cache Status: OK
   Battery/Capacitor Status: OK

Because of something todo with a new kernel version i had to run the HPacuCli tool with the uname26 command

See more inof here – http://www.legendiary.at/2012/06/21/hpacucli-does-not-work-on-kernel-3-0-wrapper-workaround-uname26/

mkdir uname26 ; cd uname26
wget http://mirror.linux.org.au/linux/kernel/people/ak/uname26/Makefile
wget http://mirror.linux.org.au/linux/kernel/people/ak/uname26/uname26.c
make
yum install cc gcc cpp
make
cp uname26 /usr/sbin

pfSense to Cisco IPSEC Tunnel

pFSense config

c

b a

Cisco Config

Replace GigabitEthernet0/0 for your interface

Replace list 100 for your NAT list

Replace the Key and IP’s

Update the Access list to reflect your subnet’s

!
crypto isakmp policy 10
encr 3des
authentication pre-share
group 2
crypto isakmp key XXXX address 1.2.3.4 no-xauth
!
!
crypto ipsec transform-set 3DES-SHA esp-3des esp-sha-hmac
!
crypto map PFSVPN 15 ipsec-isakmp
set peer 1.2.3.4
set transform-set 3DES-SHA
set pfs group2
match address encrypt-to-dc
!

interface GigabitEthernet0/0
Description WAN Interface
...
crypto map PFSVPN

ip nat inside source list 100 interface GigabitEthernet0/0 overload

access-list 100 deny   ip 192.168.20.0 0.0.0.255 192.168.30.0 0.0.0.255
access-list 100 permit ip 192.168.20.0 0.0.0.255 any

ip access-list extended encrypt-to-dc
 permit ip 192.168.20.0 0.0.0.255 192.168.30.0 0.0.0.255
!